Autor Tema: Usar PERUT en un dispositivo con soporte JAVA  (Leído 9616 veces)

Desconectado Kike_GL

  • Administrator
  • Socio PERUT
  • *
  • Mensajes: 1,705
    • Locuras 4x4
Usar PERUT en un dispositivo con soporte JAVA
« : febrero 17, 2010, 08:18:14 pm »
Si tienes un dispositivo que soporta JAVA, felicitaciones probablemente puedes instalar el navegador We travel o GpsMid y el mapas gratuitos de Perú Ruteable modificado para OSM (Ver tip abajo).

Esta es una lista de celulares con soporte JAVA, pero tener en cuenta que es solo de referencia. El que tu celular este en esta lista no garantiza que funcione en el y lo contrario tambien.

  • Nokia Classic, Prism, XpressMusic, Navigator, Fold, Slide, Surge, Supernova, 2660, 3110c, 3720, 5130, 5220, 5300, 5320, 5530, 5700, 5730, 6020, 6085, 6110, 6120, 6121, 6122, 6220, 6270, 6288, 6290, 6300, 6303, 6600, 6600, 6600i, 6650, 6700, 6708, 6720, 6730, kia 6790, 7360, 7370, 7373, 7390, 7500, 7610, E50, E52, E61i, E62, E65, E72, E75, E90, N75, N76, N77, N81, N82, N86, N93i, N95, N96, N97;
  • Sony Ericsson C510, C901, C903, D750i, Frida, G702, G900, J300, K300, K310, K330, K510, K530i, K550i, K600i, K618i, K630, K750, K758, K810, K818, M600, M608, P1, P990, S302, S500i, T303, T658, T700, T707, V640i, W200, W300, W302, W350, W380i, W395, W550, W595, W610, W700, W705, W710, W715, W800, W810, W830, W888, W902, W910i, W958, W995, Z310i, Z530, Z550, Z555, Z750i, Z770i;
  • HTC Touch Pro2, MAX 4G, MTeoR, Snap, Touch Cruise 09, Touch Diamond2, Touch HD, Touch Pro, Touch Viva, TyTN, P3300
    P3400, P3600, P4350, S630;
  • Samsung OmniaLITE, OmniaPRO, Omnia II, INNOV8, Soul, Epix, Beat Twist, Beat DJ, Star, Blade, UltraTOUCH, Impression, A777, B2100, B7300, B7320, B7610, C3110, D900i, E500, F330, F400, F510, F700, G400, G810, i620, i640, i780, I8000, i8510, i907, J165, J630, J750, L170, L700, L770, L810v, L870, M2710, M7600, P910, S5230, S5600v, s8300, S8300, SGH-D728, SGH-D830, SGH-D840, SGH-E390, SGH-E720, SGH-E740, SGH-E780, SGH-i308, SGH-i310, SGH-i688, SGH-i718, SGH-i718+, SGH-i728, SGH-L760, SGH-P310, SGH-U700V, SGH-Z400v, SGH-Z630, U800, Z170, Z220
    Z300, Z370, Z620, Z720i, ZV40;
  • Motorola 171, A1200, A1200E, A1200r, A728, A732, A780, A810, E2, E608i/g, E8, EM30, EM325, EM330, EM35, KRZR K3, L6
    L6/g, L7, Q11, Q9, RAZR maxx V6, RIZR Z3, RIZR Z8, ROKR E6e, ROKR ZN50, SLVR L7i, U9, V1000, V190, V191, V303, V361, V3i, RAZR, V3re, V3x, V3xx RAZR, V550, V600, V635, W231, W270, W360, ZN300;
  • Sagem Myw-7;
Para otras marcas ver aqui

El navegador GpsMid que puede ser intalado en dispositivos que soporten JAVA, trabaja con compactos mapas vectoriales en el formato tambien libre de OpenStreetMap - OSM almacenados en la memoria del dispositivo, por lo que no requiere conexion a internet ni genera gastos de comunicacion.

Solo tienes que bajar el instaldor desde aqui, desempaquetarlo en su PC y copien a su celular los archivos jad y el jar.

Tu celular puedo o no tener GPS no importa. Necesitaran unos 6 MB de espacio libre en el celular, para tener a la vez el instalador y el instalado, siendo conveniente borrar luego los archivos de instalación, para recuperar 2 MB.

Finalmente solo ejecuta el jad en tu celular.

Si tienes alguna consulta ponla aqui.

Perú Ruteable es un mapa vectorial en formato Garmin que para ser usado por el navegador GpsMid debe ser convertido a un formato libre llamado OSM. El ZIP ya contiene el mapa de Lima transformado y listo para instalar.


Solo tienes que bajar el instaldor desde aqui, desempaquetarlo en su PC y copien a su celular los archivos jad y el jar.

Si tienes alguna consulta ponla aqui.
Saludos, Kike_GL

Desconectado eglp

  • Administrator
  • Novato
  • *
  • Mensajes: 24
Re: Usar PERUT en un dispositivo con soporte JAVA
« Respuesta #1 : marzo 14, 2010, 12:22:06 am »
Nota importante para los usuarios de BlackBerry. Curve, PearlFlip, 8707v, 8800, 8300, 8310, 8220.

A pesar que algunos modelos de BackBerry soporan JAVA, el instalador del post anterior no  les va a servir dado que estos tienen una particular implementacion de JAVA que requiere su propio compilado (que he adjuntando a este post).

Desconectado IvoSan

  • Administrator
  • Socio PERUT
  • *
  • Mensajes: 1,021
Re: Usar PERUT en un dispositivo con soporte JAVA
« Respuesta #2 : marzo 17, 2010, 03:44:36 pm »
Nota importante para los usuarios de BlackBerry. Curve, PearlFlip, 8707v, 8800, 8300, 8310, 8220.

A pesar que algunos modelos de BackBerry soporan JAVA, el instalador del post anterior no  les va a servir dado que estos tienen una particular implementacion de JAVA que requiere su propio compilado (que he adjuntando a este post).

lo probé en un BB 8520.  El error que arrojó fue:

Error starting GpasMidBlack$2dPrueba$2d0$2e5$2e00: Symbol 'Runnable.logger' not found
Por favor, no me pidan soporte a equipos GPS en mensajes privados ni correos.